import re
regex = re.compile(r"(?|(?=\b(?:[a-z]*[A-Z]){1})(\w)|(?!^)\G(\w)(?!\b))")
test_str = "It's a simple SEnTeNCE with a FEW word."
subst = "\\1 "
result = regex.sub(subst, test_str)
if result:
print(result)