import Foundation
let pattern = #"(?|(?=\b(?:[a-z]*[A-Z]){1})(\w)|(?!^)\G(\w)(?!\b))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"It's a simple SEnTeNCE with a FEW word."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1 "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)