# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\\textbf{([^}]*)}/\1/gm;t' <<< "\textbf{1 + 1} \begin{center} \textbf{some text in here:} \end{center} and \textbf{2} etc"