use strict;
my $str = '\\textbf{1 + 1} \\begin{center} \\textbf{some text in here:} \\end{center} and \\textbf{2} etc';
my $regex = qr/\\textbf{([^}]*)}/mp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";