import re
regex = re.compile(r"\\textbf{([^}]*)}", flags=re.MULTILINE)
test_str = "\\textbf{1 + 1} \\begin{center} \\textbf{some text in here:} \\end{center} and \\textbf{2} etc"
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)