using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\\textbf{([^}]*)}";
string substitution = @"\1";
string input = @"\textbf{1 + 1} \begin{center} \textbf{some text in here:} \end{center} and \textbf{2} etc";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}