#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\\textbf{([^}]*)}"
Local $sString = "\textbf{1 + 1} \begin{center} \textbf{some text in here:} \end{center} and \textbf{2} etc"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)