import Foundation
let pattern = #"\\textbf{([^}]*)}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"\textbf{1 + 1} \begin{center} \textbf{some text in here:} \end{center} and \textbf{2} etc"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)