$re = '/\\\\textbf{([^}]*)}/m';
$str = '\\textbf{1 + 1} \\begin{center} \\textbf{some text in here:} \\end{center} and \\textbf{2} etc';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;