package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\\textbf{([^}]*)}`)
var str = `\textbf{1 + 1} \begin{center} \textbf{some text in here:} \end{center} and \textbf{2} etc`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}