using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^-?[0-9]+(?:\.[0-9]{1,4})?$";
string input = @"222,222,264.00
+2,424,24.34
-264
264.00
0.
0.11111
0.1111
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}