import re
regex = re.compile(r"^-?[0-9]+(?:\.[0-9]{1,4})?$")
test_str = ("222,222,264.00\n"
"+2,424,24.34\n"
"-264\n"
"264.00\n"
"0.\n"
"0.11111\n"
"0.1111\n")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")