import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^-?[0-9]+(?:\\.[0-9]{1,4})?$";
final String string = "222,222,264.00\n"
+ "+2,424,24.34\n"
+ "-264\n"
+ "264.00\n"
+ "0.\n"
+ "0.11111\n"
+ "0.1111\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}