import Foundation
let pattern = #"^-?[0-9]+(?:\.[0-9]{1,4})?$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
222,222,264.00
+2,424,24.34
-264
264.00
0.
0.11111
0.1111
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}