const regex = /^-?[0-9]+(?:\.[0-9]{1,4})?$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^-?[0-9]+(?:\\.[0-9]{1,4})?$', '')
const str = `222,222,264.00
+2,424,24.34
-264
264.00
0.
0.11111
0.1111
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}