$re = '/^-?[0-9]+(?:\.[0-9]{1,4})?$/';
$str = '222,222,264.00
+2,424,24.34
-264
264.00
0.
0.11111
0.1111
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);