package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^-?[0-9]+(?:\.[0-9]{1,4})?$`)
var str = `222,222,264.00
+2,424,24.34
-264
264.00
0.
0.11111
0.1111
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}