// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^-?[0-9]+(?:\.[0-9]{1,4})?$").unwrap();
let string = "222,222,264.00
+2,424,24.34
-264
264.00
0.
0.11111
0.1111
";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}