# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.*buero(.*)$/0_userdata.0$1/gm;t' <<< "0_userdata.0.mqtt.1.shellies.licht.buero.computer.temperature"