const regex = /.*buero(.*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*buero(.*)$', 'gm')
const str = `0_userdata.0.mqtt.1.shellies.licht.buero.computer.temperature`;
const subst = `0_userdata.0$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);