package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*buero(.*)$`)
var str = `0_userdata.0.mqtt.1.shellies.licht.buero.computer.temperature`
var substitution = "0_userdata.0$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}