#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m).*buero(.*)$"
Local $sString = "0_userdata.0.mqtt.1.shellies.licht.buero.computer.temperature"
Local $sSubst = "0_userdata.0$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)