using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*buero(.*)$";
string substitution = @"0_userdata.0$1";
string input = @"0_userdata.0.mqtt.1.shellies.licht.buero.computer.temperature";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}