import Foundation
let pattern = #".*buero(.*)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"0_userdata.0.mqtt.1.shellies.licht.buero.computer.temperature"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"0_userdata.0$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)