// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m).*buero(.*)$").unwrap();
let string = "0_userdata.0.mqtt.1.shellies.licht.buero.computer.temperature";
let substitution = "0_userdata.0$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}