using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?:[a-zA-Z-_]*/)+)?([a-z]+\.py)";
string input = @"Updating 46fea4e..6818c16
Fast-forward
cogs/dev.py | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
From https://github.com/JohnnyJTH/Geri_Bot
46fea4e..6818c16 master -> origin/master";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}