use strict;
my $str = 'Updating 46fea4e..6818c16
Fast-forward
cogs/dev.py | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
From https://github.com/JohnnyJTH/Geri_Bot
46fea4e..6818c16 master -> origin/master';
my $regex = qr/((?:[a-zA-Z-_]*/)+)?([a-z]+\.py)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}