import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:[a-zA-Z-_]*/)+)?([a-z]+\\.py)";
final String string = "Updating 46fea4e..6818c16\n"
+ "Fast-forward\n"
+ " cogs/dev.py | 2 +-\n"
+ " 1 file changed, 1 insertion(+), 1 deletion(-)\n\n\n"
+ "From https://github.com/JohnnyJTH/Geri_Bot\n"
+ " 46fea4e..6818c16 master -> origin/master";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}