import re
regex = re.compile(r"((?:[a-zA-Z-_]*/)+)?([a-z]+\.py)", flags=re.MULTILINE)
test_str = ("Updating 46fea4e..6818c16\n"
"Fast-forward\n"
" cogs/dev.py | 2 +-\n"
" 1 file changed, 1 insertion(+), 1 deletion(-)\n\n\n"
"From https://github.com/JohnnyJTH/Geri_Bot\n"
" 46fea4e..6818c16 master -> origin/master")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")