$re = '/((?:[a-zA-Z-_]*/)+)?([a-z]+\.py)/m';
$str = 'Updating 46fea4e..6818c16
Fast-forward
cogs/dev.py | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
From https://github.com/JohnnyJTH/Geri_Bot
46fea4e..6818c16 master -> origin/master';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);