package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)((?:[a-zA-Z-_]*/)+)?([a-z]+\.py)`)
var str = `Updating 46fea4e..6818c16
Fast-forward
cogs/dev.py | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
From https://github.com/JohnnyJTH/Geri_Bot
46fea4e..6818c16 master -> origin/master`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}