# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<a\s+id="[^"]*"[^\\/]\\/>//gmi;t' <<< "<a id=\"8\" />
jdf
sadfa
<a id=\"df\" />
<a name=\"df\" />"