re = /<a\s+id="[^"]*"[^\/]\/>/mi
str = '<a id="8" />
jdf
sadfa
<a id="df" />
<a name="df" />'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result