$re = '/<a\s+id="[^"]*"[^\/]\/>/mi';
$str = '<a id="8" />
jdf
sadfa
<a id="df" />
<a name="df" />';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;