using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a\s+id=""[^""]*""[^\/]\/>";
string substitution = @"";
string input = @"<a id=""8"" />
jdf
sadfa
<a id=""df"" />
<a name=""df"" />";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}