// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?mi)<a\s+id="[^"]*"[^\/]\/>"#).unwrap();
let string = "<a id=\"8\" />
jdf
sadfa
<a id=\"df\" />
<a name=\"df\" />";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}