const regex = /<a\s+id="[^"]*"[^\/]\/>/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<a\\s+id="[^"]*"[^\\\/]\\\/>', 'gmi')
const str = `<a id="8" />
jdf
sadfa
<a id="df" />
<a name="df" />`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);