import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<a\\s+id=\"[^\"]*\"[^\\/]\\/>";
final String string = "<a id=\"8\" />\n"
+ "jdf\n"
+ "sadfa\n"
+ "<a id=\"df\" />\n"
+ "<a name=\"df\" />";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}