use strict;
my $str = '<a id="8" />
jdf
sadfa
<a id="df" />
<a name="df" />';
my $regex = qr/<a\s+id="[^"]*"[^\/]\/>/mip;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";