#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mi)<a\s+id="[^"]*"[^\/]\/>"
Local $sString = "<a id="8" />" & @CRLF & _
"jdf" & @CRLF & _
"sadfa" & @CRLF & _
"<a id="df" />" & @CRLF & _
"<a name="df" />"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)