#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "<SQL>GEOMETRYTYPE\s*=\s*(\d+) AND RPAREA\s*=\s*(\d+)"
Local $sString = "<SQL>GEOMETRYTYPE = 10 AND RPAREA = 1112</SQL>"
Local $sSubst = "<SQL>GEOMETRYTYPE = \1 AND RPAREA = \2 AND NAME EXISTS NO"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)