const regex = new RegExp('<SQL>GEOMETRYTYPE\\s*=\\s*(\\d+) AND RPAREA\\s*=\\s*(\\d+)', 'g')
const str = `<SQL>GEOMETRYTYPE = 10 AND RPAREA = 1112</SQL>`;
const subst = `<SQL>GEOMETRYTYPE = \1 AND RPAREA = \2 AND NAME EXISTS NO`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);