import Foundation
let pattern = #"<SQL>GEOMETRYTYPE\s*=\s*(\d+) AND RPAREA\s*=\s*(\d+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"<SQL>GEOMETRYTYPE = 10 AND RPAREA = 1112</SQL>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<SQL>GEOMETRYTYPE = \1 AND RPAREA = \2 AND NAME EXISTS NO"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)