using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<SQL>GEOMETRYTYPE\s*=\s*(\d+) AND RPAREA\s*=\s*(\d+)";
string substitution = @"<SQL>GEOMETRYTYPE = \1 AND RPAREA = \2 AND NAME EXISTS NO";
string input = @"<SQL>GEOMETRYTYPE = 10 AND RPAREA = 1112</SQL>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}