$re = '/<SQL>GEOMETRYTYPE\s*=\s*(\d+) AND RPAREA\s*=\s*(\d+)/';
$str = '<SQL>GEOMETRYTYPE = 10 AND RPAREA = 1112</SQL>';
$subst = "<SQL>GEOMETRYTYPE = \1 AND RPAREA = \2 AND NAME EXISTS NO";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;