import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<SQL>GEOMETRYTYPE\\s*=\\s*(\\d+) AND RPAREA\\s*=\\s*(\\d+)";
final String string = "<SQL>GEOMETRYTYPE = 10 AND RPAREA = 1112</SQL>";
final String subst = "<SQL>GEOMETRYTYPE = \\1 AND RPAREA = \\2 AND NAME EXISTS NO";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}