// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"<SQL>GEOMETRYTYPE\s*=\s*(\d+) AND RPAREA\s*=\s*(\d+)").unwrap();
let string = "<SQL>GEOMETRYTYPE = 10 AND RPAREA = 1112</SQL>";
let substitution = "<SQL>GEOMETRYTYPE = \\1 AND RPAREA = \\2 AND NAME EXISTS NO";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}