use strict;
my $str = '<SQL>GEOMETRYTYPE = 10 AND RPAREA = 1112</SQL>';
my $regex = qr/<SQL>GEOMETRYTYPE\s*=\s*(\d+) AND RPAREA\s*=\s*(\d+)/p;
my $subst = '<SQL>GEOMETRYTYPE = \\1 AND RPAREA = \\2 AND NAME EXISTS NO';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";