re = /<SQL>GEOMETRYTYPE\s*=\s*(\d+) AND RPAREA\s*=\s*(\d+)/
str = '<SQL>GEOMETRYTYPE = 10 AND RPAREA = 1112</SQL>'
subst = '<SQL>GEOMETRYTYPE = \\1 AND RPAREA = \\2 AND NAME EXISTS NO'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result