# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/pow(\([^)]+),2\)/square\1)/gm;t' <<< "pow(alpha,2) + pow(beta,2)
(3*pow(betaR_red,2))
2/pow(gammaBlue,3))
-pow(epsilon_gamma,2)+5"